Merci de vous connecter ou de vous inscrire.

Auteur Sujet: GS60 2PC Ghost met le feu au Wi-Fi  (Lu 1873 fois)

0 Membres et 1 Invité sur ce sujet

JulienIZBAK

  • Newbie
  • *
  • :
  • Hors ligne Hors ligne
  • Messages: 11
GS60 2PC Ghost met le feu au Wi-Fi
« le: avril 01, 2015, 04:47:36 pm »

Bonjour,

Voila maintenant de nombreux mois que je suis le propriétaire d'un MSI GS60 2PC Ghost. Durant cette période j'ai eu des joies et des larmes avec ce matériel et je souhaite partager avec vous mon expérience.

Dans les premiers mois qui ont suivi mon achat, j'ai été ravi de retrouver un système performant pour mes tâches quotidiennes : programmation et navigation web essentiellement. Cela faisait 6 ans que je n'avais pas acheté de nouveau matériel et la différence avec mon iMac était flagrante.

J'ai profité de cette machine pour jouer à Diablo 3 de façon tout à fait occasionnelle. L'expérience a été concluante. Je n'ai pas joué pendant quelques mois avant de me remettre sur un autre jeu de Blizzard : World of Warcraft. J'ai eu des problèmes de ping pendant un certain temps, que j'ai essayé de résoudre via l'installation de nouveaux pilotes. Les choses sont allées de mal en pire. La latence est devenue insoutenable lors du jeu à un tel point que je finissais pas ne plus pouvoir me connecter.

Rien ne semblait indiquer de problème lors de mon utilisation bureautique. J'ai blâmé tour à tour le jeu, le système d'exploitation, les pilotes, la carte réseau et la carte graphique.

En effet, je dispose d'un routeur Wi-Fi Freebox qui opère en 2.4Ghz sur les normes B,G et N. Tous les autres appareils de la maison, téléphones, ordinateurs, tablettes et consoles, fonctionnent très bien avec cette borne. Je ne pouvais pas raisonnablement penser qu'il s'agissait d'un problème à ce niveau là.

Alors j'ai enquêté sur la carte Wi-Fi. J'ai trouvé de nombreuses plaintes et de nombreuses pistes pour mon problème. Après des heures à tester différents pilotes, je me suis résolu à envoyer la bête en RMA. Elle m'est revenue avec une carte réseau toute neuve.

Bémol : mon ordinateur était complètement infecté par un virus au retour, il manquait une visse au châssis. Le SAV m'a indirectement fait comprendre que je devais être à l'origine du problème en excluant la possibilité d'une infection lors de la réparation : ils ont parait-il des procédures. Quoi qu'il en soit, une recherche sur Google à propos du dit virus a montré qu'il s'agit d'un élément connu et identifié depuis des années et que sa signature est présente dans tous les anti-virus dignes de ce nom. Il est tout à fait impossible que mon ordinateur, parfaitement à jour, soit infecté par un virus non rootkit connu depuis des années. Mais soit, passons le temps perdu à télécharger système, pilote et jeux. Passons aussi les crises des occupants de la maison pour cause de monopolisation de la bande passante.

Finalement, je suis en mesure de tester mon nouveau matériel. A mon grand regret, le ping en mode bureau est toujours instable et devient catastrophique en jeu. Après des jours d'enquêtes, j'en arrive à la conclusion suivante : la carte intel utilise un mode de gestion d'alimentation qui fonctionne de paire avec le point d'accès. Ce dernier ne supportant pas le protocole, la carte ne fonctionne pas correctement. J'ai alors du désactiver dans les options du pilote Wi-Fi l'UASPD et mettre la puissance de transmission au maximum. C'est le moyen préconisé pour contourner cette norme de gestion intelligente de l'alimentation de la carte.

J'ai constaté un mieux mais le tout restait instable avec un débit ayant tendance à chuter. J'ai alors appris que la carte dispose de deux antennes : une pour le 5ghz, le Wi-Fi AC, et une autre pour le 2,4Ghz partagée entre le Wi-Fi et le Bluetooth. Le soucis est que mon point d'accès gère la norme N sur 2,4Ghz et non la norme AC sur 5Ghz. Ainsi le Bluetooth et le Wi-Fi utilisent la même antenne. Après désactivation de la carte Bluetooth, j'ai pu profiter d'une bonne stabilité. A ce stade je disposait d'une connexion correcte pour l'utilisation bureautique. Les transfert en local se faisant à 60mbps avec des chutes à 20mbps. Ayant quelques voisin et me tenant à quelques murs d'écart du point d'accès, ces résultats m'ont satisfait.

Je me suis alors précipité sur Starcraft 2 pour éprouver cette connexion. A peine le jeu lancé, des lags graphiques se sont fait ressentir et j'ai été déconnecté de Battle.net. Il faut savoir que c'est une tradition chez Blizzard de ne pas gérer séparément le réseau et l'affichage dans les écrans d'accueil : un problème réseau aura tendance à figer l'interface. Je me rends compte que mon ping, après être monté très haut, s'est coupé. Le fait d'avoir lancé le jeu avait rendu la connexion inutilisable, comme pour Wow auparavant.

J'ai soupçonné un problème d'alimentation de la carte réseau, en me disant que peut-être le système rognait sur l'alimentation pour nourrir la GTX. J'ai alors désactiver toutes les options de gestion de l'alimentation dans la liste des périphérique et dans le mode de gestion d'alimentation : sans succès.

Je me suis alors dis que j'allais réduire les paramètres graphiques en jeu : sans succès non plus. J'ai finalement activé la synchronisation verticale en jeu, qui a pour effet de réguler l'affichage à 60 FPS. Miracle ! Le jeu est redevenu fonctionnel !
Alors j'ai cherché d'avantage. Le problème d'alimentation était à exclure car même avec une résolution ridicule et les détails au minimum le jeu ne fonctionnait pas. Je me suis penché sur la dissipation de chaleur.

Je pensais que la carte réseau dont la plage de fonctionnement s'arrête à 80 degrés était surchauffée par le GPU. Je me suis procuré Open Hardware Monitor et j'ai enregistré la température du CPU et du GPU. Lors du lancement du jeu sans la synchronisation verticale, les deux courbes ont sauté au plafond, le CPU allant 4 degrés plus haut que le GPU. Le ventilation que je croyais insuffisante fonctionnait : les courbes se stabilisaient à leur maximum autorisé.

J'ai alors eu l'idée lumineuse de réduire la fréquence max du CPU dans les options d'alimentation : 60% de la fréquence max. Le résultat a été imédiat : une baisse de la température du CPU de près de 10 degrés et plus aucun problème de réseau lors du jeu, sans bridage de FPS.

J'en suis arrivé à la conclusion suivante :

- Intel m'a bien soulé avec sa norme d'économie d'énergie pas fonctionnelle et avec le partage de l'antenne 2,4Ghz Bluetooth et Wi-Fi.
- Il y a un problème de dissipation de chaleur au niveau de CPU qui gène la carte réseau lorsque le CPU tourne à fond.

Le premier constat appelle les solutions suivantes :
- Désactiver l'UAPSD et définir la puissance de transmission à maximale lorsque le point d'accès n'est pas compatible
- Désactiver le Bluetooth lors de l'utilisation d'un réseau 2.4Ghz

Le second constat me laisse perplexe. La solution est de ne pas trop tirer sur le CPU lorsque le réseau est nécessaire via une configuration spéciale du logiciel utilisé -- limiter les FPS -- ou brider le CPU dans les options d'alimentation.

J'ai bien essayé de refroidir l'ordinateur par le dessous, la température du disque chute de plus de 10 degrés mais les autres composants finissent pas atteindre la température max.

En somme, les ventilateurs font leur job, le CPU est bien refroidi, mais la carte réseau souffre de la chaleur en excès. Je ne vois pas comment, via la substitution d'une pièce, le problème pourrait être résolu. Il m'est inutile de faire appel au SAV de MSI.

De ce que j'ai compris, les ventilateurs refroidissent CPU et GPU mais pas l'intérieur du boitier, surtout la partie à proximité de la carte réseau. Il faudrait que je refroidisse le CPU quelques degrés plus bas pour éviter les problèmes. J'ai vu que des habitués du forum anglais modifient l'EC et jouent avec les réglages du ventillateur à leur convenance. Je me serais précipité sur cette méthode si je n'avais pas en tête le Turbo Boost d'Intel. C'est un overclocking automatique du procésseur qui se désactive lorsque celui-ci atteint sa température de fonctionnement maximale. Si j'augmente la vitesse de rotation du ventillateur sans modifier la température maximale du processeur, il y a de fortes chances pour que le Turbo Boost se lâche et que je ne sois pas en mesure de refoidir plus qu'actuellement.

Je vous partage cette expérience qui je l'espère vous sera utile. Je vais essayer de déterminer de combien je dois réduire la puissance du processeur pour ne plus avoir de problème. Je vais aussi coder un petit utilitaire pour faire tourner les cœurs au max et permettre à d'autres de tester leur machine sans télécharger 20Go de jeu Blizzard.

Si vous avez une bête similaire et que vous vous sentez l'âme d'un aventurier, vous pouvez essayer de reproduire le problème.

Merci si vous avez eu la patience de lire l'intégralité du post  ;D
« Modifié: avril 01, 2015, 06:01:57 pm par JulienIZBAK »
IP archivée

johnt31

  • Expert
  • ****
  • :
  • Hors ligne Hors ligne
  • Messages: 15 482
Re : GS60 2PC Ghost met le feu au Wi-Fi
« Réponse #1 le: avril 02, 2015, 09:48:07 am »

Slt

quel carte réseau wifi as tu en intel une AC3160 ?
IP archivée
Overcloking Master pourquoi as tu fermé tes portes :(

E4400 2Ghz@ 3.3Ghz air cooling



Skype => johnt3100

JulienIZBAK

  • Newbie
  • *
  • :
  • Hors ligne Hors ligne
  • Messages: 11
Re : GS60 2PC Ghost met le feu au Wi-Fi
« Réponse #2 le: avril 02, 2015, 11:18:32 am »

Bonjour,

Il s'agit d'une 7260 AC + Bluetooth
IP archivée

johnt31

  • Expert
  • ****
  • :
  • Hors ligne Hors ligne
  • Messages: 15 482
Re : GS60 2PC Ghost met le feu au Wi-Fi
« Réponse #3 le: avril 02, 2015, 11:46:28 am »

si j'ai bien compris tu as du ping de temps en temps
IP archivée
Overcloking Master pourquoi as tu fermé tes portes :(

E4400 2Ghz@ 3.3Ghz air cooling



Skype => johnt3100

JulienIZBAK

  • Newbie
  • *
  • :
  • Hors ligne Hors ligne
  • Messages: 11
Re : GS60 2PC Ghost met le feu au Wi-Fi
« Réponse #4 le: avril 02, 2015, 11:57:01 am »

Non en fait tout va bien sauf que quand je lance un jeu le réseau ne fonctionne plus du tout. Pour starcraft 2 ça signifie que je me fais déconnecter. Au niveau du ping ça se manifeste par "Délais de réponse dépassé" en chaine, ou un message du genre.
IP archivée

johnt31

  • Expert
  • ****
  • :
  • Hors ligne Hors ligne
  • Messages: 15 482
Re : GS60 2PC Ghost met le feu au Wi-Fi
« Réponse #5 le: avril 03, 2015, 09:00:24 am »

Slt essai ca


Comment désactiver ce scan réseau intempestif ?
1) Il faut aller dans l'éditeur de registres (regedit.exe).
2) Ctrl+F et rechercher "AdapterModel". Un dossier s'ouvre avec entre autres le nom de l'adaptateur (pour moi Intel(R) Dual Band Wireless-AC 3160).
3) Rechercher la valeur "ScanWhenAssociated". Si elle existe et que sa valeur est à 1, la passer à 0.
    Si elle n'existe pas, comme dans mon cas, la créer avec un type REG_DWORD et mettre sa valeur à 0.
4) Redémarrer la machine.

http://i.imgur.com/QEmiUCP.png


J'espère que ce post servira à d'autres car le problème est récurrent sur beaucoup de machines.
Merci johnt31 pour tes réponses régulières.

A bientôt !  ;)
IP archivée
Overcloking Master pourquoi as tu fermé tes portes :(

E4400 2Ghz@ 3.3Ghz air cooling



Skype => johnt3100